通达信sar指标请教(已解答:冷妞妞)
                                                                                                                                          2016-11-19 20:46:00   来源:股票壹网   评论:0 点击:

                                                                                                                                          通达信sar指标请教(已解答:冷妞妞) @金水杯 这两句改成这样,效果一样: IF(CLOSE>SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORRED,{COLOR9955FF}; IF(CLOSE<SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRC
                                                                                                                                            通达信sar指标请教(已解答:冷妞妞)
                                                                                                                                          @金水杯

                                                                                                                                          这两句改成这样,效果一样:
                                                                                                                                          IF(CLOSE>SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORRED,{COLOR9955FF};
                                                                                                                                          IF(CLOSE<SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN,{COLORDDFF00};

                                                                                                                                          所以是:"第一个绿点时确认前面的红点"
                                                                                                                                          REF(C,1)<REF((SAR(4,2,20),1) AND C>SAR(4,2,20);--@熊市新手2008

                                                                                                                                          老师麻烦您再给看一下谢谢--@金水杯
                                                                                                                                          多了半个“(”:

                                                                                                                                          REF(C,1)<REF(SAR(4,2,20),1) AND C>SAR(4,2,20);--@熊市新手2008  @熊市新手200 @熊市新手2008
                                                                                                                                          老师我想选出的是最后一个红点不是第一个哈麻烦老师--
                                                                                                                                          引用:
                                                                                                                                          原帖由 @金水杯 于 2016-11-20 10:47 发表
                                                                                                                                          熊市新手2008  熊市新手200 熊市新手2008
                                                                                                                                          老师我想选出的是最后一个红点不是第一个哈麻烦老师    
                                                                                                                                          你这个要用未来函数。不然今天是红点   谁也不知道这个红点是不是最后一个红点?
                                                                                                                                          如果不用未来函数就是只要今天是第一个绿点   那么昨天肯定是最后一个红点
                                                                                                                                          CROSS(CLOSE<=SAR(4,2,20),0.5);

                                                                                                                                          --@冷妞妞
                                                                                                                                          冷老师谢谢。未来不要紧,就是说当天的红点不出信号,等出绿点了反回昨天的红点出信号,信号要晚一天。麻烦老师再辛苦谢谢。--
                                                                                                                                          引用:
                                                                                                                                          原帖由 @金水杯 于 2016-11-21 13:58 发表
                                                                                                                                          冷妞妞
                                                                                                                                          冷老师谢谢。未来不要紧,就是说当天的红点不出信号,等出绿点了反回昨天的红点出信号,信号要晚一天。麻烦老师再辛苦谢谢。    
                                                                                                                                          楼上的应该可以   你试试--@冷妞妞

                                                                                                                                          REF(C,1)<REF(SAR(4,2,20),1) AND C>SAR(4,2,20);这个是第一个红点--感谢2位老师已解决谢谢--@冷妞妞 老师 你好  麻烦帮我编写选股 短线暴涨 谢谢你了 源码如下MA5:MA(C,5);
                                                                                                                                          MA6:MA(C,6);
                                                                                                                                          MA10:MA(C,10);
                                                                                                                                          MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
                                                                                                                                          MA30:MA(C,30);
                                                                                                                                          MA60:MA(C,60);
                                                                                                                                          MA120:MA(C,120);
                                                                                                                                          乖离2:=(MA20-MA30)/MA30*100;
                                                                                                                                          VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
                                                                                                                                          MAX1:=MAX(MA20,MA30);
                                                                                                                                          MAX2:=MAX(MAX1,MA60);
                                                                                                                                          MIN11:=MIN(MA20,MA30);
                                                                                                                                          MIN2:=MIN(MIN11,MA60);
                                                                                                                                          K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
                                                                                                                                          VAR2:=IF(K1<=8,1,0);
                                                                                                                                          上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
                                                                                                                                          STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
                                                                                                                                          神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
                                                                                                                                          ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,"←神枪手');
                                                                                                                                          神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
                                                                                                                                          ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}
                                                                                                                                          短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
                                                                                                                                          AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,'短线暴张'),COLORRED;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,'←买入'),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
                                                                                                                                          DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
                                                                                                                                          XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
                                                                                                                                          XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
                                                                                                                                          XL3:=CROSS(XL2,(0 - 20));
                                                                                                                                          DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');
                                                                                                                                          DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');
                                                                                                                                          X6:=REF(CLOSE,1);
                                                                                                                                          X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
                                                                                                                                          X8:=CROSS(79,X7);
                                                                                                                                          X9:=FILTER(X8,4);
                                                                                                                                          DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;
                                                                                                                                          STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
                                                                                                                                          AAA:=CONST(HHV(H,90));
                                                                                                                                          R1:=MA(CLOSE,1);
                                                                                                                                          R2:=MA(CLOSE,3);
                                                                                                                                          R3:=(MA(R2,1)*1);
                                                                                                                                          R4:=(MA(R2,3)*1);
                                                                                                                                          DRAWTEXT(CROSS(R3,R4),(LOW-0.1),'进'),COLORYELLOW;
                                                                                                                                          LC:=REF(CLOSE,1);
                                                                                                                                          RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
                                                                                                                                          FF:=EMA(CLOSE,3);
                                                                                                                                          MA15:=EMA(CLOSE,21);
                                                                                                                                          DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'出'),COLORGREEN;
                                                                                                                                          VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
                                                                                                                                          VAR12:=(HIGH+LOW+CLOSE)/3;
                                                                                                                                          VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
                                                                                                                                          VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
                                                                                                                                          VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
                                                                                                                                          VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
                                                                                                                                          VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
                                                                                                                                          VAR18:=100-ABS(VAR17);
                                                                                                                                          VAR19:=IF(VAR18<90,VAR18,100);
                                                                                                                                          VAR1A:=IF(VARE>0,VARE,0);
                                                                                                                                          VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
                                                                                                                                          VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
                                                                                                                                          DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,'大笔出货'),LINETHICK1,COLORFFCC66;
                                                                                                                                          AA1:=AMOUNT/V;
                                                                                                                                          BB1:=L<AA1*0.9;
                                                                                                                                          CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
                                                                                                                                          DD1:=L<MA(C,5)*0.921;
                                                                                                                                          EE1:=V<MA(V,5)*1.5;
                                                                                                                                          老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
                                                                                                                                          DRAWTEXT(老鼠仓,(LOW* 0.99),'老鼠仓'),COLOR40CCFF;
                                                                                                                                          A74:=MA(CLOSE,20);
                                                                                                                                          A75:=(CLOSE > MA(CLOSE,5));
                                                                                                                                          A76:=(MA(CLOSE,5) > MA(CLOSE,10));
                                                                                                                                          A77:=(CLOSE > MA(CLOSE,10));
                                                                                                                                          A78:=(MA(CLOSE,5) > MA(CLOSE,20));
                                                                                                                                          A79:=(CLOSE > MA(CLOSE,20));
                                                                                                                                          A710:=REF(A74,1);
                                                                                                                                          A711:=(A74 > A710);
                                                                                                                                          AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))
                                                                                                                                          + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
                                                                                                                                          DSLX:=(CLOSE / INDEXC);
                                                                                                                                          DSLX1:=MA(DSLX,5);
                                                                                                                                          DSLX2:=MA(DSLX,10);
                                                                                                                                          V1:=MA(VOL,5);
                                                                                                                                          V2:=MA(VOL,10);
                                                                                                                                          T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
                                                                                                                                          T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
                                                                                                                                          T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
                                                                                                                                          T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
                                                                                                                                          T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
                                                                                                                                          T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
                                                                                                                                          T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
                                                                                                                                          T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
                                                                                                                                          T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
                                                                                                                                          DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'量能股票壹,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'形态变坏,重仓者减持大半,清仓者观望'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98
                                                                                                                                          ,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股放量下跌,走势明显偏弱,离场观望'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股形态良好,强势明显,量能充足,可以继续持有'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股走势趋弱,量能不足,减持大部分筹码'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股走势太弱,没有参与价值。'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘股票壹,有明显走强迹象,中线参与,仓位在2/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘走势良好,量能股票壹,可以继续持有强势股。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000 ;
                                                                                                                                          AA:=BARSCOUNT(C);
                                                                                                                                          AH:=HHV(H,200);
                                                                                                                                          AL:=LLV(L,200);
                                                                                                                                          A0:=(AH-AL)/40;
                                                                                                                                          B1:=L-A0;
                                                                                                                                          STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;
                                                                                                                                          DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,'时间窗,变盘'),COLORF00FF0;
                                                                                                                                          VAR2S:=(2*CLOSE+HIGH+LOW)/4;
                                                                                                                                          VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
                                                                                                                                          VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
                                                                                                                                          散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
                                                                                                                                          庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
                                                                                                                                          DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←吸'),COLORRED;
                                                                                                                                          BBB1:=MA(C,1);
                                                                                                                                          B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;
                                                                                                                                          SMA2:=MA(B2,2);
                                                                                                                                          VARB1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
                                                                                                                                          VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
                                                                                                                                          买:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),'←⊙买'),COLORRED;

                                                                                                                                          DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
                                                                                                                                          DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
                                                                                                                                          DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.00,0.06,0,'主题投资:')COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNSTR(0,1))COLOR00FFFF;

                                                                                                                                          DRAWTEXT_FIX(1,0.00,0.18,0,'愚民主题概念:'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.09,0.18,0,EXTERNSTR(0,4)),COLOR00FFFF;

                                                                                                                                          DRAWTEXT_FIX(1,0.09,0.24,0,EXTERNSTR(0,3)),COLORYELLOW;--
                                                                                                                                          引用:
                                                                                                                                          原帖由 @贵派 于 2016-11-23 08:46 发表
                                                                                                                                          冷妞妞 老师 你好  麻烦帮我编写选股 短线暴涨 谢谢你了 源码如下MA5:MA(C,5);
                                                                                                                                          MA6:MA(C,6);
                                                                                                                                          MA10:MA(C,10);
                                                                                                                                          MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
                                                                                                                                          MA30:MA(C,30);
                                                                                                                                          MA60:M ...    
                                                                                                                                          MA5:=MA(C,5);
                                                                                                                                          MA6:=MA(C,6);
                                                                                                                                          MA10:=MA(C,10);
                                                                                                                                          MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
                                                                                                                                          MA30:=MA(C,30);
                                                                                                                                          MA60:=MA(C,60);
                                                                                                                                          MA120:=MA(C,120);
                                                                                                                                          乖离2:=(MA20-MA30)/MA30*100;
                                                                                                                                          VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
                                                                                                                                          MAX1:=MAX(MA20,MA30);
                                                                                                                                          MAX2:=MAX(MAX1,MA60);
                                                                                                                                          MIN11:=MIN(MA20,MA30);
                                                                                                                                          MIN2:=MIN(MIN11,MA60);
                                                                                                                                          K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
                                                                                                                                          VAR2:=IF(K1<=8,1,0);
                                                                                                                                          短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
                                                                                                                                          AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,"短线暴张');--@冷妞妞 老师你好 麻烦帮写选股公式 放心买  源码如下  {信者无敌主图}
                                                                                                                                          VAR1:=(C+H+O+L)/4;
                                                                                                                                          卖出:=XMA(VAR1,20)*(1+80/1000),POINTDOT,COLORGREEN,LINETHICK3;
                                                                                                                                          买入:=XMA(VAR1,32)*(1-100/1000),POINTDOT,COLORMAGENTA,LINETHICK3;
                                                                                                                                          幅度:=100*(卖出-买入)/买入,NODRAW;
                                                                                                                                          菩提:=买入+(卖出-买入)*2/3;{此函数仅做参考线,为提前趋势预测线,上涨途中向下见顶,下跌途中向上见底};
                                                                                                                                          般:=XMA(CLOSE,7);
                                                                                                                                          若:=MEMA(CLOSE,3);
                                                                                                                                          全绿K:=LONGCROSS(若,般,3) AND H>菩提;
                                                                                                                                          RSVL:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;   
                                                                                                                                          KL:=SMA(RSVL,3,1);   
                                                                                                                                          DL:=SMA(KL,3,1);   
                                                                                                                                          KKL:=SMA(RSVL,3,1);   
                                                                                                                                          DD:=SMA(KL,3,1);   
                                                                                                                                          NL:=KKL+DD;   
                                                                                                                                          买入L:=DRAWICON(CROSS(NL,50),50,1),COLORRED;   
                                                                                                                                          卖出L:=DRAWICON(CROSS(160,NL),160,2),COLORGREEN;   
                                                                                                                                          卖出K:=CROSS(160,NL);   
                                                                                                                                          TM:=(CLOSE*1.0+LOW*0.0+HIGH*0.0);
                                                                                                                                          T1M:=V;
                                                                                                                                          SL1M:=(TM/REF(TM,1)-1)*1000;
                                                                                                                                          趋势5:=XMA(XMA(XMA(SL1M,20),20),20),COLORYELLOW;
                                                                                                                                          趋势6:=XMA(XMA(XMA(SL1M,10),10),10),COLORMAGENTA;
                                                                                                                                          QA9:=趋势6-趋势5;
                                                                                                                                          QA10:=EMA(QA9,89);
                                                                                                                                          买入M:=(QA9-QA10)*2,COLORSTICK;
                                                                                                                                          M1:=EMA(C,5);M2:=EMA(C,13);M3:=EMA(C,34),COLORBLUE,LINETHICK2;
                                                                                                                                          MC1:=EMA(C,55);MC2:=EMA(C,89);MA4:=EMA(C,144);
                                                                                                                                          VAR1A1H:=(REF(CLOSE,1)-REF(ATR,1));
                                                                                                                                          买线1:=REF(EMA(C,14),1)COLORWHITE,LINETHICK3;
                                                                                                                                          卖线1:=IF(MC1>MAX(MC2,MA4),MC1,IF(MC1<MIN(MC2,MA4),MC2,MA4)),COLORFF00CC,LINETHICK3;
                                                                                                                                          高1:=REF(HHV(H,150),3);
                                                                                                                                          低1:=REF(LLV(L,150),3);
                                                                                                                                          STICKLINE(买线1>=卖线1,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,6,0)COLOR001050;
                                                                                                                                          STICKLINE(买线1<卖线1,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,6,0)COLOR404050;
                                                                                                                                          STICKLINE(买入M>=0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORRED;
                                                                                                                                          STICKLINE(买入M<0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORGREEN;
                                                                                                                                          STICKLINE(买入L,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,2,0)COLORYELLOW;
                                                                                                                                          STICKLINE(卖出K AND 买入M<0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,2,0)COLORCYAN;
                                                                                                                                          多空趋势彩带:DRAWBAND(SMA(C,6.5,1),RGB(255,97,0),SMA(C,13.5,1),RGB(0,128,0));
                                                                                                                                          中线:=(卖出+买入)/2,POINTDOT,COLORWHITE,LINETHICK4;
                                                                                                                                          MA5:=MA(C,5),COLOR000099;
                                                                                                                                          MA10:=MA(C,10),COLOR006600;
                                                                                                                                          MA20:=MA(C,20),COLOR005555;
                                                                                                                                          ZB1:=EMA(C,34);{ 原为55或65 }
                                                                                                                                          长期趋势:EMA(ZB1,13),COLORRED,LINETHICK3;{原为34或55}
                                                                                                                                          STICKLINE(C>=REF(C,1),O,C,3,1),COLOR000000;
                                                                                                                                          STICKLINE(C<REF(C,1),O,C,3,1),COLOR000000;
                                                                                                                                          AA3:=EMA(CLOSE,5)>EMA(CLOSE,6) AND EMA(CLOSE,6)>EMA(CLOSE,7) AND EMA(CLOSE,7)>EMA(CLOSE,8) AND EMA(CLOSE,8)>EMA(CLOSE,9)
                                                                                                                                          AND EMA(CLOSE,9)>EMA(CLOSE,10) AND EMA(CLOSE,10)>EMA(CLOSE,11) AND EMA(CLOSE,11)>EMA(CLOSE,12)
                                                                                                                                          AND EMA(CLOSE,12)>EMA(CLOSE,13) AND EMA(CLOSE,13)>EMA(CLOSE,14);
                                                                                                                                          AA2:= EMA(CLOSE,14)>EMA(CLOSE,15)
                                                                                                                                          AND EMA(CLOSE,15)>EMA(CLOSE,20) AND EMA(CLOSE,20)>EMA(CLOSE,30) AND EMA(CLOSE,30)>EMA(CLOSE,60) AND EMA(CLOSE,60)>EMA(CLOSE,90)
                                                                                                                                          AND EMA(CLOSE,90)>EMA(CLOSE,120) AND EMA(CLOSE,120)>EMA(CLOSE,250);
                                                                                                                                          A1:= AA2 AND AA3;
                                                                                                                                          A2:=EMA(CLOSE,5)>EMA(CLOSE,6) AND EMA(CLOSE,6)>EMA(CLOSE,7) AND EMA(CLOSE,7)>EMA(CLOSE,8) AND EMA(CLOSE,8)>EMA(CLOSE,9)
                                                                                                                                          AND EMA(CLOSE,9)>EMA(CLOSE,10) AND EMA(CLOSE,10)>EMA(CLOSE,11) AND EMA(CLOSE,11)>EMA(CLOSE,12)
                                                                                                                                          AND EMA(CLOSE,12)>EMA(CLOSE,13) AND EMA(CLOSE,13)>EMA(CLOSE,14);
                                                                                                                                          B1:=IF(A1,1,2);
                                                                                                                                          VAR1MZ:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
                                                                                                                                          VAR2MZ:=((REF(VAR1MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR3MZ:=((REF(VAR2MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR4MZ:=((REF(VAR3MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR5MZ:=((REF(VAR4MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR6MZ:=((REF(VAR5MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR7MZ:=((REF(VAR6MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR8MZ:=((REF(VAR7MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR9MZ:=((REF(VAR8MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VARAMZ:=((REF(VAR9MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VARBMZ:=((REF(VARAMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VARCMZ:=((REF(VARBMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          {红K}
                                                                                                                                          STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),L,H,0,0),COLOR0000DD;
                                                                                                                                          STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,REF(C,1),3,0),COLOR000099;
                                                                                                                                          STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,REF(C,1),2,0),COLOR0000BB;
                                                                                                                                          STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,REF(C,1),1,0),COLOR0000DD;

                                                                                                                                          VARDMZ:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
                                                                                                                                          VAREMZ:=((REF(VARDMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VARFMZ:=((REF(VAREMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR10MZ:=((REF(VARFMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR11MZ:=((REF(VAR10MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR12MZ:=((REF(VAR11MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR13MZ:=((REF(VAR12MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR14MZ:=((REF(VAR13MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR15MZ:=((REF(VAR14MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR16MZ:=((REF(VAR15MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          VAR17MZ:=((REF(VAR16MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
                                                                                                                                          VAR18MZ:=((REF(VAR17MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
                                                                                                                                          {绿K}
                                                                                                                                          STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,REF(C,1),3 ,0 ),COLOR00BB00;
                                                                                                                                          STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,REF(C,1),2 ,0 ),COLOR00DD00;
                                                                                                                                          STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,REF(C,1),1 ,0 ),COLOR00FF00;
                                                                                                                                          STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),H,L,0,0 ),COLOR00DD00;
                                                                                                                                          VAR19MZ:=(REF((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),1) AND VAR1MZ);
                                                                                                                                          VAR1AMZ:=(REF((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),1) AND VARDMZ);
                                                                                                                                          {粉红}
                                                                                                                                          STICKLINE(VAR19MZ,REF(CLOSE,1),REF(CLOSE,2),3 ,0 ),COLORFF11FF;
                                                                                                                                          STICKLINE(VAR19MZ,REF(CLOSE,1),REF(CLOSE,2),2 ,0 ),COLORFF44FF;
                                                                                                                                          STICKLINE(VAR19MZ,REF(CLOSE,1),REF(CLOSE,2),1 ,0 ),COLORFF66FF;
                                                                                                                                          {黄色}
                                                                                                                                          STICKLINE(VAR1AMZ,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00AAFF;
                                                                                                                                          STICKLINE(VAR1AMZ,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR00CCFF;
                                                                                                                                          STICKLINE(VAR1AMZ,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR00EEFF;
                                                                                                                                          FF:=EMA(CLOSE,3);
                                                                                                                                          MA15:=EMA(CLOSE,21);
                                                                                                                                          TTJ:=CROSS(FF,MA15);
                                                                                                                                          上:=EMA(C,3),COLORBLUE,LINETHICK1;
                                                                                                                                          中:=EMA(C,5),COLORWHITE,LINETHICK1;
                                                                                                                                          下:=EMA(中,5),COLOR00FF00,LINETHICK1;
                                                                                                                                          QQ:= C<中;
                                                                                                                                          MM:=上>REF(上,1) AND REF(上,1)<REF(上,2) ;
                                                                                                                                          V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
                                                                                                                                          V2:=(1-7/100)*(DMA(CLOSE,V1));
                                                                                                                                          V3:=(1+7/100)*(DMA(CLOSE,V1));
                                                                                                                                          V5:=MA((LOW+HIGH+CLOSE)/3,5);
                                                                                                                                          MA1Q:=MEMA(CLOSE,5);
                                                                                                                                          MA2Q:=ATAN((MA1Q/REF(MA1Q,1)-1)*100)*180/3.1416;
                                                                                                                                          MA3Q:=IF(MA2Q>0,MA2Q,MA2Q);
                                                                                                                                          MA5Q:=MA(CLOSE,5),COLOR888899;
                                                                                                                                          MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
                                                                                                                                          VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
                                                                                                                                          OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
                                                                                                                                          REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
                                                                                                                                          C>=REF(C,1) AND C>=REF(C,2);
                                                                                                                                          VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
                                                                                                                                          VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
                                                                                                                                          REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
                                                                                                                                          REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
                                                                                                                                          C<REF(C,1) AND C<REF(C,2);
                                                                                                                                          VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
                                                                                                                                          REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
                                                                                                                                          VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
                                                                                                                                          REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
                                                                                                                                          REF(C,2)>=REF(C,4) AND C<REF(C,1);
                                                                                                                                          VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
                                                                                                                                          VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;
                                                                                                                                          VAR08:=VAR07 AND COUNT(VAR06,2);
                                                                                                                                          VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
                                                                                                                                          VAR10:=EMA(MA(C,13),13);
                                                                                                                                          VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
                                                                                                                                          CROSS(VAR09,MA(VAR09,2)))=1,5);
                                                                                                                                          VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
                                                                                                                                          CROSS(MA(VAR09,2),VAR09))=1,1);
                                                                                                                                          VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
                                                                                                                                          VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
                                                                                                                                          VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
                                                                                                                                          VAR16:=VAR08 AND NOT(REF(VAR08,1));
                                                                                                                                          RSVQ:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
                                                                                                                                          K:=SMA(RSVQ,3,1);
                                                                                                                                          D:=SMA(K,3,1);
                                                                                                                                          J:=3*K-2*D;
                                                                                                                                          金叉:=CROSS(J,D);
                                                                                                                                          死叉:=CROSS(D,J);
                                                                                                                                          买1:=(VAR14 OR VAR15) AND VAR11;
                                                                                                                                          买2:=(VAR14 OR VAR15) AND VAR04;
                                                                                                                                          买3:=(VAR14 OR VAR15) AND VAR02;
                                                                                                                                          买4:=(VAR02 AND VAR11) OR (VAR04 AND VAR11);
                                                                                                                                          买5:=(金叉 AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
                                                                                                                                          TTJ0:=VAR16;
                                                                                                                                          TTJ1:=买1 OR 买2 OR 买3 OR 买4 OR 买5 AND MM;
                                                                                                                                          XG0:=TTJ AND TTJ0;
                                                                                                                                          XG1:=TTJ AND TTJ1;
                                                                                                                                          XG11:=XG0 OR XG1;
                                                                                                                                          PL5:=ZIG(3,5);
                                                                                                                                          EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
                                                                                                                                          EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
                                                                                                                                          PL10:=ZIG(3,10);
                                                                                                                                          EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
                                                                                                                                          EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
                                                                                                                                          PL20:=ZIG(3,20);
                                                                                                                                          EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
                                                                                                                                          EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
                                                                                                                                          PL40:=ZIG(3,40);
                                                                                                                                          走强1:=BARSLAST(PL5<REF(PL5,1));
                                                                                                                                          走弱1:=BARSLAST(PL5>REF(PL5,1));
                                                                                                                                          走强2:=BARSLAST(PL10<REF(PL10,1));
                                                                                                                                          走弱2:=BARSLAST(PL10>REF(PL10,1));
                                                                                                                                          走强3:=BARSLAST(PL20<REF(PL20,1));
                                                                                                                                          走弱3:=BARSLAST(PL20>REF(PL20,1));
                                                                                                                                          ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
                                                                                                                                          ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
                                                                                                                                          DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
                                                                                                                                          DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
                                                                                                                                          ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
                                                                                                                                          ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
                                                                                                                                          DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
                                                                                                                                          DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
                                                                                                                                          TJ11:=EN2 AND ZTJZ5=1;
                                                                                                                                          TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
                                                                                                                                          TJ33:=EN2 AND DTJZ10=1;
                                                                                                                                          TJ44:=EN3 AND ZTJZ10=1;
                                                                                                                                          TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
                                                                                                                                          XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
                                                                                                                                          XGQ:=XG11 OR XG22;
                                                                                                                                          W18:=EXIST(XGQ,1);
                                                                                                                                          DRAWTEXT(XGQ,L-0.1,'●放心买'),COLORRED;
                                                                                                                                          SQX:=(C-MA(CLOSE,13))*100;
                                                                                                                                          DIFF:=EMA(MA(SQX,7),1),COLORWHITE;
                                                                                                                                          DEA:=EMA(DIFF,7),COLORYELLOW;
                                                                                                                                          MACD:=(DIFF-DEA)*2,COLORSTICK;
                                                                                                                                          奉献:IF((CROSS(DIFF,DEA) AND DIFF<-0.1) ,L-0.2,DRAWNULL),COLORMAGENTA,LINETHICK9,CROSSDOT;
                                                                                                                                          低位金叉:=IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,DRAWNULL),COLORMAGENTA,LINETHICK9,CROSSDOT;
                                                                                                                                          IF(CROSS(DIFF,DEA) AND DIFF<-0.1,L-0.2,DRAWNULL),COLORYELLOW,LINETHICK4,POINTDOT;
                                                                                                                                          {再上N均线 N 10 1 100 1}
                                                                                                                                          MA1:=MA(C,5);
                                                                                                                                          MA2:=MA(C,10);
                                                                                                                                          MA3:=MA(C,21);
                                                                                                                                          破N:=REF(MA1,1)<REF(MA2,1)AND MA2>REF(MA2,1);
                                                                                                                                          试摸N:=C>MA(C,10) OR H>=MA2;
                                                                                                                                          再上N:=C>O AND REF(C,1)< MA(C,10) AND 试摸N AND 破N AND MA(C,21)<MA(C,10);
                                                                                                                                          有行情:=再上N AND (CROSS(C,长期趋势) OR CROSS(L,长期趋势) OR CROSS(H,长期趋势));
                                                                                                                                          DRAWTEXT(有行情,LOW-0.2,'●有行情'),COLORGREEN;
                                                                                                                                          VAR10B:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
                                                                                                                                          VAR11B:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
                                                                                                                                          VAR12B:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
                                                                                                                                          VAR13B:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
                                                                                                                                          VAR14B:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
                                                                                                                                          VAR15B:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
                                                                                                                                          VAR16B:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
                                                                                                                                          VAR17B:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
                                                                                                                                          VAR18B:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
                                                                                                                                          VAR19B:=EMA(CLOSE,2)-EMA(CLOSE,150);
                                                                                                                                          买1B:=VAR10B;
                                                                                                                                          买2B:=(VAR11B+VAR13B+VAR15B+VAR17B);
                                                                                                                                          BB:=IF(买1B>0 OR 买2B>0 ,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
                                                                                                                                          红买绿卖:IF(CROSS(BB,买1B),LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK5,COLORWHITE;
                                                                                                                                          牛节点:=CROSS(EMA(C,5),EMA(C,30))AND CROSS(EMA(C,10),EMA(C,20));
                                                                                                                                          DRAWICON(牛节点,L-0.1,13);
                                                                                                                                          CSAR:=SAR(10,2,20);
                                                                                                                                          持币:=IF(CSAR>=H,CSAR,0),CIRCLEDOT,COLORGREEN{持币};
                                                                                                                                          持股:=IF(CSAR<=L,CSAR,0),CIRCLEDOT,COLORRED{持股};
                                                                                                                                          生命线2:=EMA(SLOPE(C,21)*20+C,42),LINETHICK2,COLORYELLOW;{股价在上持,在下空仓}
                                                                                                                                          止损:=EMA(C,5),COLORYELLOW,LINETHICK1;{红持股绿持币黄观望}
                                                                                                                                          菩提B:=XMA(H,20);{此函数仅做参考线,为提前趋势预测线,上涨途中向下见顶,下跌途中向上见底};
                                                                                                                                          参买:=IF(止损>=REF(止损,1),止损,DRAWNULL),LINETHICK2,COLORRED;{持股前提}
                                                                                                                                          DRAWICON(CROSS(L,CSAR) AND 参买>0 AND H<菩提B AND 持股>0
                                                                                                                                          AND H>长期趋势,(LOW- 0.1),5);
                                                                                                                                          VVAR1D:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
                                                                                                                                          短底:=EMA(VVAR1D,5);
                                                                                                                                          支撑:=HHV(短底,60);
                                                                                                                                          MAN:=(SMA(HIGH,21,2) * 1.05);
                                                                                                                                          下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
                                                                                                                                          中D:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
                                                                                                                                          X1D:=EMA(中D,10);
                                                                                                                                          RSVD:=SMA(下档线,3,1);
                                                                                                                                          K大:=SMA(RSVD,3,1);
                                                                                                                                          D大:=((3 * RSVD) - (2 * K大));
                                                                                                                                          J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
                                                                                                                                          RSV24:=SMA(J12,3,1);
                                                                                                                                          K24:=SMA(RSV24,3,1);
                                                                                                                                          D24:=((3 * RSV24) - (2 * K24));
                                                                                                                                          压力位:=IF(CROSS(D24,D大),HIGH,REF(HIGH,BARSLAST(CROSS(D24,D大)))),COLORFFFFFF;
                                                                                                                                          牛浮面:=CROSS(CLOSE,MA20) AND HIGH < 压力位 AND OPEN < MA20
                                                                                                                                          AND HIGH < 支撑 AND MAN - REF(MAN,1) > 0 AND X1D - REF(X1D,1)>0 AND
                                                                                                                                          D大 < 63 AND MA20 - REF(MA20,1) > 0,COLORWHITE;
                                                                                                                                          DRAWTEXT(牛浮面,L,'●牛浮面'),COLORWHITE;
                                                                                                                                          CO:=(C-O);
                                                                                                                                          绿K:=(卖出>LOW AND 卖出<HIGH) OR (卖出>MIN(C,O) AND 卖出<MAX(C,O))
                                                                                                                                          OR  卖出<LOW;
                                                                                                                                          {全绿K}
                                                                                                                                          全绿K2:=C>卖出 OR (H>卖出 AND O>C);
                                                                                                                                          STICKLINE(全绿K2,C,O,3,0),COLOR00BB00;
                                                                                                                                          STICKLINE(全绿K2,C,O,2,0),COLOR00DD00;
                                                                                                                                          STICKLINE(全绿K2,C,O,1,0),COLOR00FF00;--@贵派  @冷妞妞 老师 这三个公式为什么不能合并 你帮我看看 谢谢 RSV14:=(CLOSE - LLV(LOW,5))/(HHV(HIGH,5) - LLV(LOW,5))-0.5;
                                                                                                                                          K14:=EMA(RSV14,3);
                                                                                                                                          D14:=EMA(K14,3);
                                                                                                                                          J14:=3*K14-2*D14;
                                                                                                                                          KDJXG:=REF(COUNT(J14<REF(J14,1),5)>=3,1) AND REF(J14,1)<-0.4 AND J14>REF(J14,1);
                                                                                                                                          手指选股:=FILTER(KDJXG,3);



                                                                                                                                          VAR1:=C-REF(C,1);
                                                                                                                                          VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
                                                                                                                                          MA5:=EMA(C,5);
                                                                                                                                          MA13:=EMA(C,13);
                                                                                                                                          UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
                                                                                                                                          DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
                                                                                                                                          短牛:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
                                                                                                                                          REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
                                                                                                                                          去除停牌:=DYNAINFO(4)>0; {去除停牌}
                                                                                                                                          去ST股:=IF(NAMELIKE('S')OR NAMELIKE('*') ,0,1);{去掉*ST和ST};


                                                                                                                                          MA5:=EMA(C,5);
                                                                                                                                          MA13:=EMA(C,13);
                                                                                                                                          UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
                                                                                                                                          DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
                                                                                                                                          HR:=HHV(HIGH,55);
                                                                                                                                          HRY:=LLV(LOW,55);
                                                                                                                                          HRY11:=HR*HRY;
                                                                                                                                          HRY33:=SQRT(HRY11);
                                                                                                                                          大牛:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;


                                                                                                                                          XG:(大牛and短牛 AND 手指选股 AND 去除停牌 AND 去ST股)AND手指选股;--@冷妞妞 老师你好 麻烦你帮选股公式 当出现 红色或粉红色柱时 预警 谢谢你了 源码如下 持股线:=EMA(C,26);
                                                                                                                                          PLOYLINE(MA(C,3)>持股线,持股线),COLORFF00FF,LINETHICK2;
                                                                                                                                          PLOYLINE(MA(C,3)<持股线,持股线),COLORFFFF00,LINETHICK2;
                                                                                                                                          WW1:=FILTER(O<REF(L,1) AND C>O AND VOL>REF(V,1),13);
                                                                                                                                          JH:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
                                                                                                                                          SZ:=FILTER(CROSS(JH,35),13);
                                                                                                                                          SX:=FILTER(CROSS(JH,30),7);
                                                                                                                                          SQ:=FILTER(CROSS(71,JH),74);
                                                                                                                                          SD:=FILTER(CROSS(80,JH),74);
                                                                                                                                          AA:=IF(CAPITAL<1,SZ,SX);
                                                                                                                                          BB:=IF(CAPITAL<1,SQ,SD);
                                                                                                                                          CC:=REF(HHV(CLOSE,120),1);DD:=REF(LLV(CLOSE,120),1);
                                                                                                                                          WW:=((100 * (CLOSE - DD)) / (CC - DD));EE:=AMOUNT;
                                                                                                                                          FF:=(EMA(EE,5) / REF(EMA(EE,5),5));
                                                                                                                                          霸占:=FILTER(((((((FF >= 2)) AND (WW < 35))) AND (BARSCOUNT(CLOSE) > 30)) OR (((((FF >= 2)) AND (WW < 100))) AND (BARSCOUNT(CLOSE) < 50))),90);
                                                                                                                                          STICKLINE(C>REF(C,1),H,L,0,0),COLOR0099FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,3.2,0),COLOR0000AA;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,2.7,0),COLOR0000DD;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,2.1,0),COLOR0022FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,1.5,0),COLOR0066FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,0.9,0),COLOR0099FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,0.3,0),COLOR00DDFF;
                                                                                                                                          STICKLINE(C<REF(C,1),H,L,0,1),COLORFF8800;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,3.2,0),COLOR990000;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,2.7,0),COLORCC0000;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,2.1,0),COLORFF4400;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,1.5,0),COLORFF8800;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,0.9,0),COLORFFCC00;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,0.3,0),COLORFFDD00;
                                                                                                                                          STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,2.7,0),COLOR777777;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,2.1,0),COLOR999999;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,1.5,0),COLORBBBBBB;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,0.9,0),COLORDDDDDD;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,0.3,0),COLORFFFFFF;
                                                                                                                                          {STICKLINE(霸占,HIGH,LOW,0,1),COLOR0000FF;}
                                                                                                                                          STICKLINE(霸占,C,O,3,2),COLOR000055;
                                                                                                                                          STICKLINE(霸占,C,O,2.7,0),COLOR000077;
                                                                                                                                          STICKLINE(霸占,C,O,2.1,0),COLOR000099;
                                                                                                                                          STICKLINE(霸占,C,O,1.5,0),COLOR0000BB;
                                                                                                                                          STICKLINE(霸占,C,O,0.9,0),COLOR0000DD;
                                                                                                                                          STICKLINE(霸占,C,O,0.3,0),COLOR0000FF;
                                                                                                                                          {STICKLINE(WW1,HIGH,LOW,0,1),COLORFF55FF;}
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,3.2,0),COLORBB00FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,2.7,0),COLORFF33FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,2.1,0), COLORFF66FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,1.5,0),COLORFF99FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,0.9,0),COLORFFBBFF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,0.3,0),COLORFFDDFF;
                                                                                                                                          {STICKLINE(AA,HIGH,LOW,0,1),COLORYELLOW;}
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR0088FF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,2.7,0),COLOR00AAFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,2.1,0),COLOR00CCFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR22FFFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,0.9,0),COLOR66FFFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,0.3,0),COLOR99FFFF;
                                                                                                                                          {STICKLINE(BB,HIGH,LOW,0,1),COLOR00FF00;}
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR005500;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,2.7,0),COLOR007700;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,2.1,0),COLOR009900;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,1.5,0),COLOR00BB00;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,0.9,0),COLOR00DD00;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,0.3,0),COLOR00FF00;--@冷妞妞  谢谢老师 我是新手 麻烦你编辑选股 当k线形成多头 上涨过程中回调并触及绿线上方的红线时预警 这个有难度 麻烦老师费心了 源码如下 持股线:=EMA(C,26);
                                                                                                                                          PLOYLINE(MA(C,3)>持股线,持股线),COLORFF00FF,LINETHICK2;
                                                                                                                                          PLOYLINE(MA(C,3)<持股线,持股线),COLORFFFF00,LINETHICK2;
                                                                                                                                          WW1:=FILTER(O<REF(L,1) AND C>O AND VOL>REF(V,1),13);
                                                                                                                                          JH:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
                                                                                                                                          SZ:=FILTER(CROSS(JH,35),13);
                                                                                                                                          SX:=FILTER(CROSS(JH,30),7);
                                                                                                                                          SQ:=FILTER(CROSS(71,JH),74);
                                                                                                                                          SD:=FILTER(CROSS(80,JH),74);
                                                                                                                                          AA:=IF(CAPITAL<1,SZ,SX);
                                                                                                                                          BB:=IF(CAPITAL<1,SQ,SD);
                                                                                                                                          CC:=REF(HHV(CLOSE,120),1);DD:=REF(LLV(CLOSE,120),1);
                                                                                                                                          WW:=((100 * (CLOSE - DD)) / (CC - DD));EE:=AMOUNT;
                                                                                                                                          FF:=(EMA(EE,5) / REF(EMA(EE,5),5));
                                                                                                                                          霸占:=FILTER(((((((FF >= 2)) AND (WW < 35))) AND (BARSCOUNT(CLOSE) > 30)) OR (((((FF >= 2)) AND (WW < 100))) AND (BARSCOUNT(CLOSE) < 50))),90);
                                                                                                                                          STICKLINE(C>REF(C,1),H,L,0,0),COLOR0099FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,3.2,0),COLOR0000AA;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,2.7,0),COLOR0000DD;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,2.1,0),COLOR0022FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,1.5,0),COLOR0066FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,0.9,0),COLOR0099FF;
                                                                                                                                          STICKLINE(C>REF(C,1),C,O,0.3,0),COLOR00DDFF;
                                                                                                                                          STICKLINE(C<REF(C,1),H,L,0,1),COLORFF8800;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,3.2,0),COLOR990000;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,2.7,0),COLORCC0000;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,2.1,0),COLORFF4400;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,1.5,0),COLORFF8800;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,0.9,0),COLORFFCC00;
                                                                                                                                          STICKLINE(C<REF(C,1),C,O,0.3,0),COLORFFDD00;
                                                                                                                                          STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,2.7,0),COLOR777777;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,2.1,0),COLOR999999;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,1.5,0),COLORBBBBBB;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,0.9,0),COLORDDDDDD;
                                                                                                                                          STICKLINE(C=REF(C,1),C,O,0.3,0),COLORFFFFFF;
                                                                                                                                          {STICKLINE(霸占,HIGH,LOW,0,1),COLOR0000FF;}
                                                                                                                                          STICKLINE(霸占,C,O,3,2),COLOR000055;
                                                                                                                                          STICKLINE(霸占,C,O,2.7,0),COLOR000077;
                                                                                                                                          STICKLINE(霸占,C,O,2.1,0),COLOR000099;
                                                                                                                                          STICKLINE(霸占,C,O,1.5,0),COLOR0000BB;
                                                                                                                                          STICKLINE(霸占,C,O,0.9,0),COLOR0000DD;
                                                                                                                                          STICKLINE(霸占,C,O,0.3,0),COLOR0000FF;
                                                                                                                                          {STICKLINE(WW1,HIGH,LOW,0,1),COLORFF55FF;}
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,3.2,0),COLORBB00FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,2.7,0),COLORFF33FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,2.1,0), COLORFF66FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,1.5,0),COLORFF99FF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,0.9,0),COLORFFBBFF;
                                                                                                                                          STICKLINE(WW1,CLOSE,OPEN,0.3,0),COLORFFDDFF;
                                                                                                                                          {STICKLINE(AA,HIGH,LOW,0,1),COLORYELLOW;}
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR0088FF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,2.7,0),COLOR00AAFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,2.1,0),COLOR00CCFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR22FFFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,0.9,0),COLOR66FFFF;
                                                                                                                                          STICKLINE(AA,CLOSE,OPEN,0.3,0),COLOR99FFFF;
                                                                                                                                          {STICKLINE(BB,HIGH,LOW,0,1),COLOR00FF00;}
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR005500;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,2.7,0),COLOR007700;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,2.1,0),COLOR009900;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,1.5,0),COLOR00BB00;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,0.9,0),COLOR00DD00;
                                                                                                                                          STICKLINE(BB,CLOSE,OPEN,0.3,0),COLOR00FF00;--
                                                                                                                                          引用:
                                                                                                                                          原帖由 @贵派 于 2016-12-17 21:41 发表
                                                                                                                                          冷妞妞  谢谢老师 我是新手 麻烦你编辑选股 当k线形成多头 上涨过程中回调并触及绿线上方的红线时预警 这个有难度 麻烦老师费心了 源码如下 持股线:=EMA(C,26);
                                                                                                                                          PLOYLINE(MA(C,3)>持股线,持股线),COLORFF00FF,LIN ...    
                                                                                                                                          持股线:=EMA(C,26);
                                                                                                                                          A:=PLOYLINE(MA(C,3)>持股线,持股线);
                                                                                                                                          B:=PLOYLINE(MA(C,3)<持股线,持股线);
                                                                                                                                          A>B AND CROSS(C,A);--@冷妞妞 老师你好 我有一创意 公式合并不了 你帮看看 谢谢了  持股线:=EMA(C,26);
                                                                                                                                          A:=PLOYLINE(MA(C,3)>持股线,持股线);
                                                                                                                                          B:=PLOYLINE(MA(C,3)<持股线,持股线);
                                                                                                                                          A>B AND CROSS(C,A);
                                                                                                                                          HIGH<(REF(LOW,1)-0.001) "| LOW>(REF(HIGH,1)+0.001);--@冷妞妞 谢谢老师回复 麻烦你编辑选股  时间窗 源码如下 MA5:MA(C,5);
                                                                                                                                          MA6:MA(C,6);
                                                                                                                                          MA10:MA(C,10);
                                                                                                                                          MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
                                                                                                                                          MA30:MA(C,30);
                                                                                                                                          MA60:MA(C,60);
                                                                                                                                          MA120:MA(C,120);
                                                                                                                                          乖离2:=(MA20-MA30)/MA30*100;
                                                                                                                                          VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
                                                                                                                                          MAX1:=MAX(MA20,MA30);
                                                                                                                                          MAX2:=MAX(MAX1,MA60);
                                                                                                                                          MIN11:=MIN(MA20,MA30);
                                                                                                                                          MIN2:=MIN(MIN11,MA60);
                                                                                                                                          K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
                                                                                                                                          VAR2:=IF(K1<=8,1,0);
                                                                                                                                          上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
                                                                                                                                          STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
                                                                                                                                          神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
                                                                                                                                          ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,'←神枪手');
                                                                                                                                          神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
                                                                                                                                          ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}
                                                                                                                                          短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
                                                                                                                                          AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,'短线暴张'),COLORRED;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,'←买入'),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
                                                                                                                                          DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
                                                                                                                                          XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
                                                                                                                                          XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
                                                                                                                                          XL3:=CROSS(XL2,(0 - 20));
                                                                                                                                          DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');
                                                                                                                                          DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');
                                                                                                                                          X6:=REF(CLOSE,1);
                                                                                                                                          X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
                                                                                                                                          X8:=CROSS(79,X7);
                                                                                                                                          X9:=FILTER(X8,4);
                                                                                                                                          DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;
                                                                                                                                          STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
                                                                                                                                          AAA:=CONST(HHV(H,90));
                                                                                                                                          R1:=MA(CLOSE,1);
                                                                                                                                          R2:=MA(CLOSE,3);
                                                                                                                                          R3:=(MA(R2,1)*1);
                                                                                                                                          R4:=(MA(R2,3)*1);
                                                                                                                                          DRAWTEXT(CROSS(R3,R4),(LOW-0.1),'进'),COLORYELLOW;
                                                                                                                                          LC:=REF(CLOSE,1);
                                                                                                                                          RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
                                                                                                                                          FF:=EMA(CLOSE,3);
                                                                                                                                          MA15:=EMA(CLOSE,21);
                                                                                                                                          DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'出'),COLORGREEN;
                                                                                                                                          VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
                                                                                                                                          VAR12:=(HIGH+LOW+CLOSE)/3;
                                                                                                                                          VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
                                                                                                                                          VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
                                                                                                                                          VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
                                                                                                                                          VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
                                                                                                                                          VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
                                                                                                                                          VAR18:=100-ABS(VAR17);
                                                                                                                                          VAR19:=IF(VAR18<90,VAR18,100);
                                                                                                                                          VAR1A:=IF(VARE>0,VARE,0);
                                                                                                                                          VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
                                                                                                                                          VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
                                                                                                                                          DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,'大笔出货'),LINETHICK1,COLORFFCC66;
                                                                                                                                          AA1:=AMOUNT/V;
                                                                                                                                          BB1:=L<AA1*0.9;
                                                                                                                                          CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
                                                                                                                                          DD1:=L<MA(C,5)*0.921;
                                                                                                                                          EE1:=V<MA(V,5)*1.5;
                                                                                                                                          老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
                                                                                                                                          DRAWTEXT(老鼠仓,(LOW* 0.99),'老鼠仓'),COLOR40CCFF;
                                                                                                                                          A74:=MA(CLOSE,20);
                                                                                                                                          A75:=(CLOSE > MA(CLOSE,5));
                                                                                                                                          A76:=(MA(CLOSE,5) > MA(CLOSE,10));
                                                                                                                                          A77:=(CLOSE > MA(CLOSE,10));
                                                                                                                                          A78:=(MA(CLOSE,5) > MA(CLOSE,20));
                                                                                                                                          A79:=(CLOSE > MA(CLOSE,20));
                                                                                                                                          A710:=REF(A74,1);
                                                                                                                                          A711:=(A74 > A710);
                                                                                                                                          AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))
                                                                                                                                          + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
                                                                                                                                          DSLX:=(CLOSE / INDEXC);
                                                                                                                                          DSLX1:=MA(DSLX,5);
                                                                                                                                          DSLX2:=MA(DSLX,10);
                                                                                                                                          V1:=MA(VOL,5);
                                                                                                                                          V2:=MA(VOL,10);
                                                                                                                                          T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
                                                                                                                                          T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
                                                                                                                                          T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
                                                                                                                                          T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
                                                                                                                                          T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
                                                                                                                                          T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
                                                                                                                                          T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
                                                                                                                                          T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
                                                                                                                                          T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
                                                                                                                                          DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'量能股票壹,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'形态变坏,重仓者减持大半,清仓者观望'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98
                                                                                                                                          ,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股放量下跌,走势明显偏弱,离场观望'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股形态良好,强势明显,量能充足,可以继续持有'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股走势趋弱,量能不足,减持大部分筹码'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股走势太弱,没有参与价值。'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘股票壹,有明显走强迹象,中线参与,仓位在2/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘走势良好,量能股票壹,可以继续持有强势股。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000 ;
                                                                                                                                          AA:=BARSCOUNT(C);
                                                                                                                                          AH:=HHV(H,200);
                                                                                                                                          AL:=LLV(L,200);
                                                                                                                                          A0:=(AH-AL)/40;
                                                                                                                                          B1:=L-A0;
                                                                                                                                          STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;
                                                                                                                                          DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,'时间窗,变盘'),COLORF00FF0;
                                                                                                                                          VAR2S:=(2*CLOSE+HIGH+LOW)/4;
                                                                                                                                          VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
                                                                                                                                          VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
                                                                                                                                          散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
                                                                                                                                          庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
                                                                                                                                          DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←吸'),COLORRED;
                                                                                                                                          BBB1:=MA(C,1);
                                                                                                                                          B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;
                                                                                                                                          SMA2:=MA(B2,2);
                                                                                                                                          VARB1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
                                                                                                                                          VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
                                                                                                                                          买:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),'←⊙买'),COLORRED;

                                                                                                                                          DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
                                                                                                                                          DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
                                                                                                                                          DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.00,0.06,0,'主题投资:')COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNSTR(0,1))COLOR00FFFF;

                                                                                                                                          DRAWTEXT_FIX(1,0.00,0.18,0,'愚民主题概念:'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.09,0.18,0,EXTERNSTR(0,4)),COLOR00FFFF;

                                                                                                                                          DRAWTEXT_FIX(1,0.09,0.24,0,EXTERNSTR(0,3)),COLORYELLOW;--@冷妞妞 谢谢老师 这个源码 绝对底部 选股 源码如下 MA5:MA(C,5);
                                                                                                                                          MA6:MA(C,6);
                                                                                                                                          MA10:MA(C,10);
                                                                                                                                          MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
                                                                                                                                          MA30:MA(C,30);
                                                                                                                                          MA60:MA(C,60);
                                                                                                                                          MA120:MA(C,120);
                                                                                                                                          乖离2:=(MA20-MA30)/MA30*100;
                                                                                                                                          VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
                                                                                                                                          MAX1:=MAX(MA20,MA30);
                                                                                                                                          MAX2:=MAX(MAX1,MA60);
                                                                                                                                          MIN11:=MIN(MA20,MA30);
                                                                                                                                          MIN2:=MIN(MIN11,MA60);
                                                                                                                                          K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
                                                                                                                                          VAR2:=IF(K1<=8,1,0);
                                                                                                                                          上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
                                                                                                                                          STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
                                                                                                                                          神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
                                                                                                                                          ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,'←神枪手');
                                                                                                                                          神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
                                                                                                                                          ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}
                                                                                                                                          短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
                                                                                                                                          AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,'短线暴张'),COLORRED;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,'←买入'),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
                                                                                                                                          DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
                                                                                                                                          DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
                                                                                                                                          XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
                                                                                                                                          XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
                                                                                                                                          XL3:=CROSS(XL2,(0 - 20));
                                                                                                                                          DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');
                                                                                                                                          DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');
                                                                                                                                          X6:=REF(CLOSE,1);
                                                                                                                                          X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
                                                                                                                                          X8:=CROSS(79,X7);
                                                                                                                                          X9:=FILTER(X8,4);
                                                                                                                                          DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;
                                                                                                                                          STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
                                                                                                                                          AAA:=CONST(HHV(H,90));
                                                                                                                                          R1:=MA(CLOSE,1);
                                                                                                                                          R2:=MA(CLOSE,3);
                                                                                                                                          R3:=(MA(R2,1)*1);
                                                                                                                                          R4:=(MA(R2,3)*1);
                                                                                                                                          DRAWTEXT(CROSS(R3,R4),(LOW-0.1),'进'),COLORYELLOW;
                                                                                                                                          LC:=REF(CLOSE,1);
                                                                                                                                          RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
                                                                                                                                          FF:=EMA(CLOSE,3);
                                                                                                                                          MA15:=EMA(CLOSE,21);
                                                                                                                                          DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'出'),COLORGREEN;
                                                                                                                                          VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
                                                                                                                                          VAR12:=(HIGH+LOW+CLOSE)/3;
                                                                                                                                          VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
                                                                                                                                          VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
                                                                                                                                          VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
                                                                                                                                          VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
                                                                                                                                          VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
                                                                                                                                          VAR18:=100-ABS(VAR17);
                                                                                                                                          VAR19:=IF(VAR18<90,VAR18,100);
                                                                                                                                          VAR1A:=IF(VARE>0,VARE,0);
                                                                                                                                          VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
                                                                                                                                          VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
                                                                                                                                          DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,'大笔出货'),LINETHICK1,COLORFFCC66;
                                                                                                                                          AA1:=AMOUNT/V;
                                                                                                                                          BB1:=L<AA1*0.9;
                                                                                                                                          CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
                                                                                                                                          DD1:=L<MA(C,5)*0.921;
                                                                                                                                          EE1:=V<MA(V,5)*1.5;
                                                                                                                                          老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
                                                                                                                                          DRAWTEXT(老鼠仓,(LOW* 0.99),'老鼠仓'),COLOR40CCFF;
                                                                                                                                          A74:=MA(CLOSE,20);
                                                                                                                                          A75:=(CLOSE > MA(CLOSE,5));
                                                                                                                                          A76:=(MA(CLOSE,5) > MA(CLOSE,10));
                                                                                                                                          A77:=(CLOSE > MA(CLOSE,10));
                                                                                                                                          A78:=(MA(CLOSE,5) > MA(CLOSE,20));
                                                                                                                                          A79:=(CLOSE > MA(CLOSE,20));
                                                                                                                                          A710:=REF(A74,1);
                                                                                                                                          A711:=(A74 > A710);
                                                                                                                                          AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))
                                                                                                                                          + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
                                                                                                                                          DSLX:=(CLOSE / INDEXC);
                                                                                                                                          DSLX1:=MA(DSLX,5);
                                                                                                                                          DSLX2:=MA(DSLX,10);
                                                                                                                                          V1:=MA(VOL,5);
                                                                                                                                          V2:=MA(VOL,10);
                                                                                                                                          T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
                                                                                                                                          T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
                                                                                                                                          T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
                                                                                                                                          T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
                                                                                                                                          T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
                                                                                                                                          T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
                                                                                                                                          T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
                                                                                                                                          T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
                                                                                                                                          T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
                                                                                                                                          T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
                                                                                                                                          T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
                                                                                                                                          DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'量能股票壹,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'形态变坏,重仓者减持大半,清仓者观望'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98
                                                                                                                                          ,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股放量下跌,走势明显偏弱,离场观望'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股形态良好,强势明显,量能充足,可以继续持有'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股走势趋弱,量能不足,减持大部分筹码'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'该股走势太弱,没有参与价值。'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘股票壹,有明显走强迹象,中线参与,仓位在2/3左右'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORFF00FF ;
                                                                                                                                          DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘走势良好,量能股票壹,可以继续持有强势股。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000 ;
                                                                                                                                          DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
                                                                                                                                          ,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000 ;
                                                                                                                                          AA:=BARSCOUNT(C);
                                                                                                                                          AH:=HHV(H,200);
                                                                                                                                          AL:=LLV(L,200);
                                                                                                                                          A0:=(AH-AL)/40;
                                                                                                                                          B1:=L-A0;
                                                                                                                                          STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;
                                                                                                                                          DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,'时间窗,变盘'),COLORF00FF0;
                                                                                                                                          VAR2S:=(2*CLOSE+HIGH+LOW)/4;
                                                                                                                                          VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
                                                                                                                                          VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
                                                                                                                                          散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
                                                                                                                                          庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
                                                                                                                                          DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←吸'),COLORRED;
                                                                                                                                          BBB1:=MA(C,1);
                                                                                                                                          B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;
                                                                                                                                          SMA2:=MA(B2,2);
                                                                                                                                          VARB1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
                                                                                                                                          VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
                                                                                                                                          买:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),'←⊙买'),COLORRED;

                                                                                                                                          DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
                                                                                                                                          DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
                                                                                                                                          DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.00,0.06,0,'主题投资:')COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNSTR(0,1))COLOR00FFFF;

                                                                                                                                          DRAWTEXT_FIX(1,0.00,0.18,0,'愚民主题概念:'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT_FIX(1,0.09,0.18,0,EXTERNSTR(0,4)),COLOR00FFFF;

                                                                                                                                          DRAWTEXT_FIX(1,0.09,0.24,0,EXTERNSTR(0,3)),COLORYELLOW;
                                                                                                                                           金水杯:   2016-11-19 20:46
                                                                                                                                             如何选出sar指标的最后一个红点,即出现第一个绿点时确认前面的红点为最后一个红点,谢谢

                                                                                                                                          IF(CLOSE>=SAR(4,2,20),SAR(4,2,20),
                                                                                                                                          DRAWNULL),CIRCLEDOT,COLORRED,{COLOR9955FF};
                                                                                                                                          IF(CLOSE<=SAR(4,2,20),SAR(4,2,20),
                                                                                                                                          DRAWNULL),CIRCLEDOT,COLORGREEN,{COLORDDFF00};

                                                                                                                                          [ 本帖最后由 任刚 于 2016-11-21 16:36 编辑 ]

                                                                                                                                           股票专家荐股少而精.成功率达95%免费个股咨询点这里

                                                                                                                                           想了解手头持有个股接下来的走势个股论坛-股票吧点击这里

                                                                                                                                          通达信sar指标请教(已解答:冷妞妞)..更多详情请加腾飞涨停微信:gupiao139

                                                                                                                                          相关热词搜索:通达信 LED

                                                                                                                                          上一篇:请老师帮忙写一个连续两天量能饱和度等于50的选股
                                                                                                                                          下一篇:(已解决非常感谢冷妞妞老师)请老师帮忙写一个k线组合选股

                                                                                                                                          本栏点击总排行
                                                                                                                                          分享到: 收藏
                                                                                                                                          短信荐股回顾
                                                                                                                                          邮件传真荐股回顾
                                                                                                                                          整网点击月排行
                                                                                                                                          整网点击排行