[终结版]最强黄金分割尺+斐波那契周期(主图通达信源码指标副图)
                                                                                                                                          2016-10-23 20:10:00   来源:股票壹网   评论:0 点击:

                                                                                                                                          [终结版]最强黄金分割尺+斐波那契周期(主图通达信源码指标副图) 引用:原帖由 @云枫添外 于 2016-10-23 20:10 发表 黄金分割点 0 618运用到各个行业,在指标的用法我就不赘述了,大家动动手指搜搜。
                                                                                                                                            [终结版]最强黄金分割尺+斐波那契周期(主图通达信源码指标副图)
                                                                                                                                          引用:
                                                                                                                                          原帖由 @云枫添外 于 2016-10-23 20:10 发表
                                                                                                                                          黄金分割点 0.618  运用到各个行业,在指标的用法我就不赘述了,大家动动手指搜搜。
                                                                                                                                          本质表以指定周期的最高和最低点,用黄金分割的方式画点标值,
                                                                                                                                          红竖线表示最低点上升分割和相对数值,绿竖线表示最高点下跌分割 ...    
                                                                                                                                          非常感恩老师的分享,祝福吉祥如意!--留用..........................

                                                                                                                                          粉 1111

                                                                                                                                          --非常感恩老师的分享,祝福吉祥如意!--谢谢分享。。。。。。。--谢谢老师精彩分享!!!--顶起来,谢谢老师。。。。。--谢谢--谢谢老师精彩分享!!!--谢谢分享。。。。。。。。。。。。。。。。。--周末愉快!!--非常感恩老师的分享--晚上好!谢谢!辛苦了!                                                                                                                                    --谢谢楼主的分享精神--谢谢!非常实用。--input:K(1,1,3);
                                                                                                                                          A:=BARSLAST(DISPSTATUS=1)+1;
                                                                                                                                          HH:=HHV(H,A);
                                                                                                                                          LL:=LLV(L,A);
                                                                                                                                          上涨:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(L=LL)+1)),COLOR0000FF,linethick0;
                                                                                                                                          ↑空间%:(C/REF(L,上涨)-1)*100,COLOR00FFFF,linethick0;
                                                                                                                                          最高%:(HHVALL(HH)/REF(L,上涨)-1)*100,COLORFF00FF,linethick0;
                                                                                                                                          下跌:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(H=HH)+1)),COLOR00FF00,linethick0;
                                                                                                                                          ↓空间%:(C/REF(H,下跌)-1)*100,COLOR998888,linethick0;
                                                                                                                                          最低%:(LLVALL(LL)/REF(H,下跌)-1)*100,COLORFF0000,linethick0;
                                                                                                                                          高:REF(H,下跌),COLOR0000FF,DOTLINE;
                                                                                                                                          低:REF(L,上涨),COLOR00FF00,DOTLINE;
                                                                                                                                          VERTLINE(上涨=0,4),COLOR0000FF;
                                                                                                                                          VERTLINE(下跌=0,3),COLOR00FF00;
                                                                                                                                          {DRAWTEXT(上涨=0,HHVALL(HH)*0.99,"-最高'),COLOR0000FF;
                                                                                                                                          DRAWTEXT(下跌=0,LLVALL(LL)*1.01,'-最低'),COLOR00FF00;}

                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>10,LL*1.1,'-10%'),COLORYELLOW;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>10,LL*1.15,'-15%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>20,LL*1.2,'-20%'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>25,LL*1.25,'-25%'),COLORFF00FF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>30,LL*1.3,'-30%'),COLOR0000FF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>40,LL*1.4,'-40%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>50,LL*1.5,'-50%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>60,LL*1.6,'-60%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>70,LL*1.7,'-70%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>80,LL*1.8,'-80%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>90,LL*1.9,'-90%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>100,LL*2,'-100%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>125,LL*2.25,'-125%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>150,LL*2.5,'-150%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>180,LL*2.8,'-180%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>200,LL*3,'-200%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=0 AND 最高%>250,LL*3.5,'-250%'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-10,HH*0.9,'-10%'),COLORYELLOW;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-15,HH*0.85,'-15%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-20,HH*0.8,'-20%'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-25,HH*0.75,'-25%'),COLORFF00FF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-30,HH*0.7,'-30%'),COLORFF0000;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-40,HH*0.6,'-40%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-50,HH*0.5,'-50%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-60,HH*0.4,'-60%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-70,HH*0.3,'-70%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-80,HH*0.2,'-80%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(下跌=0 AND 最低%<-90,HH*0.1,'-90%'),COLORFFFFFF;
                                                                                                                                          DRAWTEXT(上涨=2,L,'3天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=4,L,'5天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=7,L,'8天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=12,L,'13天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=20,L,'21天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=33,L,'34天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=54,L,'55天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=88,L,'89天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=143,L,'144天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=179,L,'180天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(上涨=249,L,'250天'),COLOR00FFFF;
                                                                                                                                          DRAWTEXT(下跌=2,L,'-3天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=4,L,'-5天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=7,L,'-8天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=12,L,'-13天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=20,L,'-21天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=33,L,'-34天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=54,L,'-55天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=88,L,'-89天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=143,L,'-144天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=179,L,'-180天'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(下跌=249,L,'-250天'),COLOR00FF00;



                                                                                                                                          T := BARSLAST(DISPSTATUS=1)+1;
                                                                                                                                          Aa:= DISPSTATUS=2;
                                                                                                                                          HH1 := HHV(H, T);
                                                                                                                                          LL1 := LLV(L, T);
                                                                                                                                          HL := HH1-LL1;
                                                                                                                                          wH := HHVBARS(H, T);
                                                                                                                                          wL := LLVBARS(L, T);
                                                                                                                                          KK := wH-wL;
                                                                                                                                          mHL := HH-HL*0.5;
                                                                                                                                          if K=1 then begin
                                                                                                                                          HL191 := (HH1-LL1)*0.191;
                                                                                                                                          HL382 := (HH1-LL1)*0.382;
                                                                                                                                          HL618 := (HH1-LL1)*0.618;
                                                                                                                                          HL809 := (HH1-LL1)*0.809;
                                                                                                                                          if KK<0 then begin
                                                                                                                                          a1 := HH1-HL191;
                                                                                                                                          a2 := HH1-HL382;
                                                                                                                                          a3 := HH1-HL618;
                                                                                                                                          a4 := HH1-HL809;
                                                                                                                                          end else begin
                                                                                                                                          a1 := LL1+HL191;
                                                                                                                                          a2 := LL1+HL382;
                                                                                                                                          a3 := LL1+HL618;
                                                                                                                                          a4 := LL1+HL809;
                                                                                                                                          end
                                                                                                                                          end
                                                                                                                                          if k=1 then begin
                                                                                                                                          HL125 := (HH1-LL1)*0.125;
                                                                                                                                          HL250 := (HH1-LL1)*0.25;
                                                                                                                                          HL375 := (HH1-LL1)*0.375;
                                                                                                                                          HL625 := (HH1-LL1)*0.625;
                                                                                                                                          HL750 := (HH1-LL1)*0.75;
                                                                                                                                          HL875 := (HH1-LL1)*0.875;
                                                                                                                                          if kk<0 then begin
                                                                                                                                          b1 := HH1-HL125;
                                                                                                                                          b2 := HH1-HL250;
                                                                                                                                          b3 := HH1-HL375;
                                                                                                                                          b4 := HH1-HL625;
                                                                                                                                          b5 := HH1-HL750;
                                                                                                                                          b6 := HH1-HL875;
                                                                                                                                          end else begin
                                                                                                                                          b1 := LL1+HL125;
                                                                                                                                          b2 := LL1+HL250;
                                                                                                                                          b3 := LL1+HL375;
                                                                                                                                          b4 := LL1+HL625;
                                                                                                                                          b5 := LL1+HL750;
                                                                                                                                          b6 := LL1+HL875;
                                                                                                                                          end
                                                                                                                                          end
                                                                                                                                          DRAWTEXT(Aa and K<>3,HH1, ' 最高价:'+HH1),ALIGN2,colorgreen;
                                                                                                                                          DRAWTEXT(Aa and K<>3,LL1, ' 最低价:'+ll1),ALIGN2,VALIGN2,colorgreen;
                                                                                                                                          DRAWTEXT(Aa and K<>3,mHL,' 50%:'+mHL),ALIGN2,ColorC0C0C0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a1, ' 0.191:'+NUMTOSTRN(a1,2)),ALIGN2,ColorC0C0C0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a2, ' 0.382:'+NUMTOSTRN(a2,2)),ALIGN2,ColorC0C0C0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a3, ' 0.618:'+NUMTOSTRN(a3,2)),ALIGN2,ColorC0C0C0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a4, ' 0.809:'+NUMTOSTRN(a4,2)),ALIGN2,ColorC0C0C0;
                                                                                                                                          DRAWTEXT(Aa and K<>3,HH1, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
                                                                                                                                          DRAWTEXT(Aa and K<>3,LL1, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
                                                                                                                                          DRAWTEXT(Aa and K<>3,mHL,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorff0000,linethick7;
                                                                                                                                          DRAWTEXT(Aa and K=1, a1, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a2, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a3, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
                                                                                                                                          DRAWTEXT(Aa and K=1, a4, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;--谢谢分享。。。。。投资愉快。。。。。。。--谢谢分享  周末愉快--谢谢老师精彩分享--想到没有共享币没法下载时的感受,我忍不住把我知道的源码放出来


                                                                                                                                          GD:=CONST(FINDHIGH(H,0,高点*10,1));
                                                                                                                                          DD:=CONST(FINDLOW(L,0,低点*10,1));
                                                                                                                                          GT:=CONST(BARSLAST(GD=H))+1;
                                                                                                                                          DT:=CONST(BARSLAST(DD=L))+1;
                                                                                                                                          SH:=CONST(IF(GT=1,H,REF(H,GT-1)));
                                                                                                                                          SL:=CONST(IF(DT=1,L,REF(L,DT-1)));
                                                                                                                                          CC:=IF(DT>GT,DT,GT);
                                                                                                                                          CD:=INTPART(CC-(DT+GT)/2);
                                                                                                                                          CG:=IF(高点>CD,CD/2,高点);
                                                                                                                                          {黄金分割}
                                                                                                                                          ZG:=IF(CURRBARSCOUNT<=CD,SH,DRAWNULL);
                                                                                                                                          DRAWBAND(ZG,RGB(0,0,0),ZG,RGB(0,0,0)),DOTLINE,COLORLIRED;
                                                                                                                                          ZD:=IF(CURRBARSCOUNT<=CD,SL,DRAWNULL);
                                                                                                                                          DRAWBAND(ZD,RGB(0,0,0),ZD,RGB(0,0,0)),DOTLINE,COLORLIRED;
                                                                                                                                          X191:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.191,DRAWNULL);
                                                                                                                                          DRAWBAND(X191,RGB(0,0,0),X191,RGB(0,0,0)),DOTLINE,COLORLIRED;
                                                                                                                                          X382:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.382,DRAWNULL);
                                                                                                                                          DRAWBAND(X382,RGB(0,0,0),X382,RGB(0,0,0)),DOTLINE,COLORLIRED;
                                                                                                                                          X500:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.500,DRAWNULL);
                                                                                                                                          DRAWBAND(X500,RGB(0,0,0),X500,RGB(0,0,0)),DOTLINE,COLORRED;
                                                                                                                                          X618:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.618,DRAWNULL);
                                                                                                                                          DRAWBAND(X618,RGB(0,0,0),X618,RGB(0,0,0)),DOTLINE,COLORLIRED;
                                                                                                                                          X809:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.809,DRAWNULL);
                                                                                                                                          DRAWBAND(X809,RGB(0,0,0),X809,RGB(0,0,0)),DOTLINE,COLORLIRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(ZD)*1.02,STRCAT('起点:  ',CON2STR(ZD,2))),COLORLIGRAY;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(X191)*0.986,STRCAT('80.9%  ',CON2STR(X191,2))),COLORLIGRAY;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(X382)*0.985,STRCAT('61.8%  ',CON2STR(X382,2))),COLORLIGRAY;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(X500)*0.984,STRCAT('50%  ',CON2STR(X500,2))),COLORLIGRAY;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(X618)*0.982,STRCAT('38.2%  ',CON2STR(X618,2))),COLORLIGRAY;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(X809)*0.98,STRCAT('19.1%  ',CON2STR(X809,2))),COLORLIGRAY;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=CG,(ZG)*0.98,STRCAT('100%  ',CON2STR(ZG,2))),COLORLIGRAY;

                                                                                                                                          {斐波那契周期}
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-2 ,L*0.98,'3'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-4 ,L*0.98,'5'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-7 ,L*0.98,'8'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-12 ,L*0.98,'13'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-20 ,L*0.98,'21'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-33 ,L*0.98,'34 '),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-54 ,L*0.98,'55'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-88 ,L*0.98,'89'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-143 ,L*0.98,'144'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-232 ,L*0.98,'233'),COLOR00FF00;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT-376 ,L*0.98,'377'),COLOR00FF00;

                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-2,H,'3'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-4,H,'5'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-7,H,'8'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-12,H,'13'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-20,H,'21'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-33,H,'34'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-54,H,'55'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-88,H,'89'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-143,H,'144'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-232,H,'233'),DRAWABOVE,COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT-376,H,'377'),DRAWABOVE,COLORRED;
                                                                                                                                          {幅度尺}
                                                                                                                                          STICKLINE(CURRBARSCOUNT=IF(DT<GT,DT,GT),SH,SL,0,-1),COLORRED;
                                                                                                                                          STICKLINE(CURRBARSCOUNT=IF(DT>GT,DT,GT),SH,SL,0,-1),COLORGREEN;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.1,STRCAT('一10%   ',CON2STR(SH-SH*0.1,2))),COLORBLUE;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.15,STRCAT('一15%   ',CON2STR(SH-SH*0.15,2))),COLORCYAN;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.2,STRCAT('一20%   ',CON2STR(SH-SH*0.2,2))),COLORGREEN;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.3,STRCAT('一30%   ',CON2STR(SH-SH*0.3,2))),COLORWHITE;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.4,STRCAT('一40%   ',CON2STR(SH-SH*0.4,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.5,STRCAT('一50%   ',CON2STR(SH-SH*0.5,2))),COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.6,STRCAT('一60%   ',CON2STR(SH-SH*0.6,2))),COLORLIMAGENTA;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.7,STRCAT('一70%   ',CON2STR(SH-SH*0.7,2))),COLORMAGENTA;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.8,STRCAT('一80%   ',CON2STR(SH-SH*0.8,2))),COLORWHITE;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.9,STRCAT('一90%   ',CON2STR(SH-SH*0.9,2))),COLORGREEN;

                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.1,STRCAT('一10%  ',CON2STR(SL*1.1,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.15,STRCAT('一15%  ',CON2STR(SL*1.15,2))),COLORWHITE;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.2,STRCAT('一20%  ',CON2STR(SL*1.2,2))),COLORGREEN;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.25,STRCAT('一25%  ',CON2STR(SL*1.25,2))),COLORLIMAGENTA;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.3,STRCAT('一30%  ',CON2STR(SL*1.3,2))),COLORRED;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.4,STRCAT('一40%  ',CON2STR(SL*1.4,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.5,STRCAT('一50%  ',CON2STR(SL*1.5,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.6,STRCAT('一60%  ',CON2STR(SL*1.6,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.7,STRCAT('一70%  ',CON2STR(SL*1.7,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.8,STRCAT('一80%  ',CON2STR(SL*1.8,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*1.9,STRCAT('一90%  ',CON2STR(SL*1.9,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*2,STRCAT('一100%  ',CON2STR(SL*2,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*2.25,STRCAT('一125%  ',CON2STR(SL*2.25,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*2.5,STRCAT('一150%  ',CON2STR(SL*2.5,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*2.75,STRCAT('一175%  ',CON2STR(SL*2.75,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*3,STRCAT('一200%  ',CON2STR(SL*3,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*3.5,STRCAT('一250%  ',CON2STR(SL*3.5,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*3.75,STRCAT('一275%  ',CON2STR(SL*375,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*4,STRCAT('一300%  ',CON2STR(SL*4,2))),COLORYELLOW;
                                                                                                                                          DRAWTEXT(CURRBARSCOUNT=DT,SL*5,STRCAT('一400%  ',CON2STR(SL*5,2))),COLORYELLOW;
                                                                                                                                           云枫添外:   2016-10-23 20:10
                                                                                                                                             1-黄金分割点 0.618 能运用到不同行业各个领域,足以说明他的强大之处,
                                                                                                                                            在指标中的用法我就不赘述了,大家动动手指搜搜,论坛里百度上比比皆是。
                                                                                                                                          2-本指标以指定周期的最高和最低点,用黄金分割的方式画点标值,
                                                                                                                                            红竖线表示最低点上升分割和相对数值,绿竖线表示最高点下跌分割和相对数值。
                                                                                                                                            再以当前屏(主图)的高低值加以黄金分割(黄色横线),在横向黄金分割点标百分百。
                                                                                                                                          3-指标不但可以观察对应的高低幅度和周期,十字光标下更可以查看每个K线下的高低幅度和周期等数值。
                                                                                                                                          4-指标涵盖了我其它指标的精髓要意,如 《九天尺》 《目标预测》 《区间统计》等。
                                                                                                                                          5-高低点用参数调节,可以调到自己想要的位置。
                                                                                                                                          说明见下图:




                                                                                                                                          黄金分割尺.tne (13.05 KB) 下载:459次
                                                                                                                                              黄金分割尺.txt (7.04 KB) 预览附件 下载:163次

                                                                                                                                          两个文件源码都一样,第一个文件不用设参数,直接引入。

                                                                                                                                          [ 本帖最后由 云枫添外 于 2016-10-23 22:33 编辑 ]

                                                                                                                                           股票专家荐股少而精.成功率达95%免费个股咨询点这里

                                                                                                                                           想了解手头持有个股接下来的走势个股论坛-股票吧点击这里

                                                                                                                                          [终结版]最强黄金分割尺+斐波那契周期(主图通达信源码指标副图)..更多详情请加腾飞涨停微信:gupiao139

                                                                                                                                          相关热词搜索:通达信 黄金

                                                                                                                                          上一篇:筹码获利,找出低位单峰密集的股票(指标通达信和益盟操盘手副图贴图)
                                                                                                                                          下一篇:阴线狙击指标(指标副图通达信贴图)

                                                                                                                                          本栏点击总排行
                                                                                                                                          分享到: 收藏
                                                                                                                                          短信荐股回顾
                                                                                                                                          邮件传真荐股回顾
                                                                                                                                          整网点击月排行
                                                                                                                                          整网点击排行